stalls in reverse - Jeeps Canada - Jeep Forums

Jeep Grand Cherokee Forum Forum for all ZJ (1993 - 1998), WJ (1999-2004) and WK (Since 05) Grand Cherokee owners.

stalls in reverse

Reply

 
 
 
Old 08-19-2009, 04:18 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2009
Location: st marys
Posts: 5
Default stalls in reverse

Hello I have a 2003 Jeep Grand Cherokee . When you shift into reverse it keeps stalling . It has a 4 liter engine . Any ideas why it is doing this ? Thanks alot for the help.
jakerboy is offline  
Reply With Quote
Old 08-19-2009, 04:57 PM
  #2  
Moderator
 
CrazyWJ242's Avatar
 
Join Date: Feb 2009
Location: New Brunswick
Posts: 889
Default Re: stalls in reverse

has it triggered the check engine light?

is it when you first start it up, and go to back out of the driveway, or even when its warmed up, just going to reverse shuts it down.... have you tried letting it hang out in neutral? and see if its just when the RPM's get too low...

just a bit more info can go along way...
CrazyWJ242 is offline  
Reply With Quote
Old 08-20-2009, 12:36 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Aug 2009
Location: st marys
Posts: 5
Default Re: stalls in reverse

Hello It stalls in reverse when it is warm and when it is cold . I ran a scan and there is no codes .We just got back from a 2000km trip into northern Ontario . It ran fine the whole trip . The tranny fluid was changed in june , It revs okay in netural , have to keep the revs up to keep it running in reverse Hope this will help . Thanks again .
jakerboy is offline  
Reply With Quote
Old 08-20-2009, 01:11 AM
  #4  
Moderator
 
CrazyWJ242's Avatar
 
Join Date: Feb 2009
Location: New Brunswick
Posts: 889
Default Re: stalls in reverse

it starts up fine and keeps a smooth idle?... im just wondering if there may be an issue with the idle air control valve on the throttle body, when the RPM's drop down to idle when you go to shift, and you go to put it into reverse... and the valve doesn't open, it just chokes out the motor... its on the side of the throttlebody facing the valve cover... it has 4 torx screws securing it, some seafoam would clean it right up...

that and id check the vacuum line going to the transmission and transfer case and make sure their attached (just a regular rubber hose on the top of the transmission and t-case...) although i think this is unlikely the issue...

did this problem start up around the time of the transmission fluid change?
CrazyWJ242 is offline  
Reply With Quote
Old 08-20-2009, 01:42 AM
  #5  
Senior Member
 
04WJGuy's Avatar
 
Join Date: Nov 2008
Location: Somewhere between NE and SW Alberta
Posts: 1,216
Default Re: stalls in reverse

Maybe the IAC but if the response is yes to the last question I would start looking at the transmission governor and the pressure sensor.
Hopefully they didn't dump anything other than ATF+4 into the tranny when they changed the fluid.
04WJGuy is offline  
Reply With Quote
Old 08-20-2009, 09:28 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Aug 2009
Location: st marys
Posts: 5
Default Re: stalls in reverse

Hello Thanks for the replies. It just started to do this a few days ago . I will try the seafoam . I will let you know if this helps . Thanks
jakerboy is offline  
Reply With Quote
Old 08-21-2009, 06:51 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Aug 2009
Location: st marys
Posts: 5
Default Re: stalls in reverse

Hello . I got the stalling problem fixed. It was a broke wire . Easy fix but hard to find !! Thanks for all of the help. Helpful site .
jakerboy is offline  
Reply With Quote
Old 08-21-2009, 08:36 PM
  #8  
Moderator
 
CrazyWJ242's Avatar
 
Join Date: Feb 2009
Location: New Brunswick
Posts: 889
Default Re: stalls in reverse

sweet

was the wire down at the transmission? or was it up by the intake?
CrazyWJ242 is offline  
Reply With Quote
Old 08-22-2009, 08:09 AM
  #9  
Junior Member
Thread Starter
 
Join Date: Aug 2009
Location: st marys
Posts: 5
Default Re: stalls in reverse

It is down by the tranny . When shifted into revervse it would shake it enough tomake the engine stall.
jakerboy is offline  
Reply With Quote
Old 11-05-2017, 11:12 PM
  #10  
Junior Member
 
Join Date: Nov 2017
Location: THOMSON
Posts: 1
Default Re: stalls in reverse

Hey I am actually having this same exact problem with my 03 jeep and I just had my tranny replaced in may by some very good people. Is there any way you can tell me exactly where this wire was and what it was for? I have been having this issue for some time and I really dont want to replace my tranny again i replaced the computer thinking that was it but im still having the same issue? Any help would truly be appreciated.
Anonymous is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: stalls in reverse


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Page generated in 0.14058 seconds with 17 queries