2007 Laredo signal problem - Jeeps Canada - Jeep Forums

Jeep Grand Cherokee Forum Forum for all ZJ (1993 - 1998), WJ (1999-2004) and WK (Since 05) Grand Cherokee owners.

2007 Laredo signal problem

Reply

 
 
 
Old 12-08-2011, 10:37 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2011
Location: calgary alberta
Posts: 2
Canada 2007 Laredo signal problem

My rear driver's signal light won't work when the headlights are on but it does work when the headlights are off. The bulb is fine. Anyone have this trouble and how did you fix the problem? thanks
myles2007 is offline  
Reply With Quote
Old 12-13-2011, 12:56 AM
  #2  
Senior Member
 
04WJGuy's Avatar
 
Join Date: Nov 2008
Location: Somewhere between NE and SW Alberta
Posts: 1,216
Default Re: 2007 Laredo signal problem

The lights are controlled through the bus wiring system, you'll have to get it diagnosed at the dealer unless you have access to a DBRIII machine.
04WJGuy is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
myles2007
Jeep Cherokee Forum
0
12-08-2011 10:32 AM
Ted Borck
Jeep Mailing List
15
11-25-2005 04:05 PM
Simon Juncal
Jeep Mailing List
21
11-06-2003 01:38 AM
M. E. Bye
Jeep Mailing List
34
09-22-2003 02:50 AM
sdlomi
Jeep Mailing List
0
07-23-2003 06:26 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2007 Laredo signal problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Page generated in 0.10302 seconds with 9 queries